[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Unable to save modifications to some files  XML
Forum Index -> Jaikoz Issues Go to Page: 1, 2 Next 
Author Message
mbulgueroni



Joined: 29/11/2009 16:37:41
Messages: 1
Offline

Hello,

Just bought the software and really liked it, but it has been having problems saving to a lot of files on my MacBook with Snow Leopard 10.6.2. There is no specific files having trouble, since after a reboot for example some files which were failing to save could be saved, others not....

The error seen on the screen and on the console is the following:

Nov 29, 2009 8:47:14 PM: SEVERE: There was a problem changing some files,these have been left with status of changed
Nov 29, 2009 8:47:14 PM: SEVERE: Unable to save record 1 with filename 01 Nothing Like You (When You're Gone).mp3 because of the following error: java.util.ArrayList cannot be cast to org.jaudiotagger.tag.id3.AbstractID3v2Frame
Nov 29, 2009 8:47:14 PM: INFO: Completed Saving of 0 Songs
Nov 29, 2009 8:47:14 PM: INFO: Completed Deletion of 0 Songs

Java Version Build is as follows (preinstalled with the OS):
java version "1.6.0_15"
Java(TM) SE Runtime Environment (build 1.6.0_15-b03-219)
Java HotSpot(TM) 64-Bit Server VM (build 14.1-b02-90, mixed mode)

I am getting really frustrated with this, Do you have any clue?

Thanks!

Marcelo
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7485
Online

Hi Marcelo

This looks like a bug in the underlying tagger library dealing with some existing field that you seem to be using alot. I can fix this but I really need you to email me your support files (Advanced/Create Support Files) and preferably a file having this problem.

thanks Paul (Administrator)
Antono

Pro
[Avatar]

Joined: 22/10/2007 02:05:01
Messages: 26
Offline

Hi Paul,

I started having the same issue here. What's more, it started appearing on files that I didn't have a any problems before. Could it be the most recent update?

I am now unable to save changes to the "date" in over 2000 files (previously edited with Jaikoz)! The program returns the exact same error.

Using Jaikoz 3.4.2 (1075)
Java Version 1.6.0_17 from Sun Microsystems Inc.
Windows XP SP3
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7485
Online

Hi, the original poster never sent me his support files so I couldnt work out the problem, if you send me yours I should be able to resolve this for a new release forthcoming next week

thanks Paul (Administrator)
Antono

Pro
[Avatar]

Joined: 22/10/2007 02:05:01
Messages: 26
Offline

Thanks Paul,

Support files sent, plus one of the offending audio files.
zeiss74



Joined: 28/01/2010 00:16:35
Messages: 8
Offline

same problem here:

Unable to save record [N] with filename [Filename].mp3 because of the following error: java.util.ArrayList cannot be cast to org.jaudiotagger.tag.id3.AbstractID3v2Frame

i did create a custom field called "from" with mediamonkey recently, but i'm not sure if this is a problem or not.

i'm trying to update about 800-1000 files, and i can't determine which are causing the problem, or which were saved properly, if any.

Using Jaikoz 3.4.2 (1075)
Java version is Version 6 Update 14
Windows 7 32 bit
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7485
Online

Hi zeiss74 . please send me your support files (Advanced/Create Support Files) as well because your problem might not be exactly the same.

thanks Paul (Administrator)
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7485
Online

Antonos problem fixed in dev, cannot say if this will resolve other issues at this point.

thanks Paul (Administrator)
zeiss74



Joined: 28/01/2010 00:16:35
Messages: 8
Offline

sent. thanks for looking into this, and let me know if there are any interim fixes in the works. i can't really use the program for anything until this is fixed, since my changes are not being saved. cheers!
zeiss74



Joined: 28/01/2010 00:16:35
Messages: 8
Offline

btw, i upgraded my java to 6-18, but that didn't fix anything.
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7485
Online

zeiss74 Jaikoz 3.4.3 released this second, try it out and see if it resolves your issue.

thanks Paul (Administrator)
zeiss74



Joined: 28/01/2010 00:16:35
Messages: 8
Offline

thanks for the quick fix, but unfortunately i still have the same problem. i installed over my old install, but get the same java error. would it do any good to send my support files today?

(i didn't reboot or anything other than install and test.)
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7485
Online

Yes please do, together with one of the problem files

thanks Paul (Administrator)
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7485
Online

zeiss74 I wonder did you actually get the new version jaikoz 3.4.3 , the version on MacUpdate is still 3.4.2

thanks Paul (Administrator)
zeiss74



Joined: 28/01/2010 00:16:35
Messages: 8
Offline

i'm on windows, so i downloaded and installed 3.4.3 manually, and i confirmed it within the software.

"Jan 29, 2010 8:02:36 AM: INFO: Jaikoz 3.4.3 using Java 1.6.0_18 16.0-b13 32bit on Windows 7 6.1 x86 initialized successfully "

just sent files. btw, i noticed the support zip files overwrites itself without asking. is that a preference setting? it might be nice if the filename included a time/date stamp.
zeiss74



Joined: 28/01/2010 00:16:35
Messages: 8
Offline

also, if this helps your troubleshooting: i have yet to find a file that i *can* save, at least that i've noticed. so i don't think it is a quirky property in a given file (i.e., track name contains ! or " or something like that).

if you have anything you want me to investigate on my end, i'd be happy to (with the exception that i'm at work for the next 7 hours)
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7485
Online

I think there was a problem with the build in that the last fixes were not included, please download again and retry. If you go to Help/About (Windows) or Jaikoz/About Jaikoz (Mac) the Build Date will say 28/01/2010 if you have the correct latest version.

thanks Paul (Administrator)
zeiss74



Joined: 28/01/2010 00:16:35
Messages: 8
Offline

seems to be fixed! thanks!

i'll keep playing with it for a while, and i'll let you know if anything unusual happens.
Antono

Pro
[Avatar]

Joined: 22/10/2007 02:05:01
Messages: 26
Offline

paultaylor wrote:
Antonos problem fixed in dev, cannot say if this will resolve other issues at this point. 


Thanks Paul,

Sorry for the late reply, internet was down.

I'm happy to report that my problem was indeed fixed in the latest version.
tom


[Avatar]

Joined: 31/10/2010 18:25:06
Messages: 9
Location: Tom
Offline

hi, i just bought the software tonight. First 50 looked good - several gaps but a big improvement. Then loaded 500 (I have c40k tunes on ms home server for squeezebox) - software on server (same drive as music folder)operated by remote desktop from xp rev 3. Already learned that some mp3 files could be locked so ran read only clear on all directories and children tho folders remain read only (I'm told thats an XP standard to support efficient folder search etc) - however, the 500 had more than 30 errors (no idea how many more than 30 because the error pop-up stopped at 30) where changes could not be written to files so I assume it's a local file write permission issue still? Can you help please? I'm now running a slug of 10,000 while you get chance to reply. Regards Tom
[WWW]
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7485
Online

If you click on the console tab on the detail panel you can see all errors.

If the folders are read only that could well cause problem because sometimes we need to write changes to a temporary file so we can ensure the write was successful before replacing the original file, so try making the folders writeable.

thanks Paul (Administrator)
tom


[Avatar]

Joined: 31/10/2010 18:25:06
Messages: 9
Location: Tom
Offline

Hi Paul, Jaikoz is still running so I can't read report yet but i also cant remove the folder attrib "read only", I had made sure yesterday that all files had write permissions ie read only removed but checking ms forums (I'm xp sp 3 laptop connected remote to windows home server 2003 as administrator, files in d:\music and Jaikox running on server on same disk) they say read only is fixed for folders in XP - even using attrib command in dos runs but doesn't remove folder attrib of +r. Are we sure this is the problem please and if so, any idea how to make folders in XP writable as opposed to their file contents (which already are) please? Cheers, Tom
[WWW]
tom


[Avatar]

Joined: 31/10/2010 18:25:06
Messages: 9
Location: Tom
Offline

Also Paul, discogs server just booted me out for 5000 enquiries in a day - I had the strong impression that this software was aimed particularly at users with large music collections, so is this an error please? Cheers, Tom
[WWW]
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7485
Online

tom wrote:
Also Paul, discogs server just booted me out for 5000 enquiries in a day - I had the strong impression that this software was aimed particularly at users with large music collections, so is this an error please? Cheers, Tom  

The main database that Jaikoz has used since inception was Musicbrainz, this has no limits. Discogs was added quite recently in order to provide some addoitional supporting data/alternative data supply, and yes it currently has a limit of 5000 lookups per day, but they have said they are looking to remove that limit.

thanks Paul (Administrator)
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7485
Online

No I'm not sure , but would be easier if you just run a test against a single folder that you are having problems with. But why can you not make the folder writable using Windows Explorer) by selecting properties and using the Security tab ?

thanks Paul (Administrator)
tom


[Avatar]

Joined: 31/10/2010 18:25:06
Messages: 9
Location: Tom
Offline

Hi Paul, many thanks for the replies - I think it's an issue outside of Jaikoz but presumably a regular challenge as I think it's a permission issue from burning tunes to disk then uploading to the server - most of my library is bought from internet strores but my initial collection of cd,s I ripped to mp3 and burnt to dvd - I'm beginning to think these folders were set to read only when burned and carry that value over when moved. So, in attempting to alter the read only I've tried explorer and it seems that every single folder is read only. I checked other forums and it seems that microsoft set all folder properties this way in XP and Win7 - and their workaround is attrib in dos - so I set all folders and children to -r but it didnt remove the tick in explorer file properties - so I used security and set user group "everyone" to full privilidges, went back to explorer properties and the read only flag still isnt clear. I've even tried "Clear read only" and "attribute changer" software but I'm unable to remove the read only flags. I'm a bit out of my depth here but I can't figure out why I can't remove the flag? your help would, of course, be much appreciated please Paul. Cheers Tom
[WWW]
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7485
Online

Hi Tom

I'm afraid the intricacies of Windows security is beyond me also, perhaps try copying the folders to a new location, maybe the new folders will no longer have this read only problem.

I still don't understand why you cant just change the permissions in Windows, are you saying that in Windows they are not marked as read only, but really they are behind the scenes.


thanks Paul (Administrator)
tom


[Avatar]

Joined: 31/10/2010 18:25:06
Messages: 9
Location: Tom
Offline

Hi Paul
what I'm saying is that once i get into the detail - EVERY folder seems to be read only - when I check Microsoft threads - they say XP and up locks all folders read only but files can be whatever - all the music files are -R but all folders throughout the system and my 2 laptops are +R. Attrib wont change it, creating full powers for user "Everyone" under security tab doesnt allow them to be cleared and using explorer clears them but re-visit and they are clearly still +R. On balance therefore I dont think its a folder +R issue - maybe its the fact I'm remote to a ms homeserver 2003 outfit (although I'm logged in as admin). It's sure got me stuimped right now and maybe your right, maybe copy some test files to a local machine, install Jaikoz local and see if it goes away? Strange thing is - more files can be written to than can't. Jeeze. Thanks for your patience. Tom
[WWW]
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7485
Online

Can you also send me your support files (Advanced/Create Support FIles)

thanks Paul (Administrator)
tom


[Avatar]

Joined: 31/10/2010 18:25:06
Messages: 9
Location: Tom
Offline

Thanks for all your speedy replies Paul - I'd be delighted to but I may be onto something. I'm just running a few small sample files thro Jaikoz. Neither of us believed it was a Jaikoz problem - more a file write permissions issue. For a different reason, I re-booted the server last night and hey presto, it appears that the security/user group/file ownership/cascade to all folders and children/inheritance rights - seem to have stuck. maybe the security settings need a re-boot but it's news to me. I'll do some more tests before I bother you with any more work if thats OK thanks Paul.
[WWW]
 
Forum Index -> Jaikoz Issues Go to Page: 1, 2 Next 
Go to:   
Powered by JForum 2.1.6 © JForum Team