[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
FIXED: Interface freezes for no reason, nothing in log file afterwards  XML
Forum Index -> Jaikoz Issues
Author Message
vodsonic



Joined: 07/09/2010 14:42:13
Messages: 6
Offline

I'm using Jaikoz 3.7.1, build 1082, on a Mac running Snow Leopard. I've been working with files in my userspace on my internal hard drive, so no external/network drive issues here. I bought Jaikoz two days ago.

Jaikoz freezes for me occasionally, usually when I'm just trying to select a tag or two. This apparently occurs at random, and I haven't noticed anything specific that sets it off, other than that I'll be in the middle of cleaning up some auto-corrected tags, usually trying to select a tag field or two in the Edit screen, and it will hang.

The blue spinning ball appears, and I can't select anything else on the screen. All of the menu options are grayed out, except for the Jaikoz menu, and I can view and use the About and Preferences windows. In Finder's "Force Quit" window, Jaikoz is NOT labeled "not responding". I can grab the window and move it around on the screen. I can also quit Jaikoz, which gives me the option of saving my changes. If I click "Yes", it does save my tags, and then closes. If I start it up again, it works normally for a while.

I've waited 10-15 minutes when it freezes, but it's never come right until I quit and start Jaikoz again. It always happens when I'm in the middle of selecting tags.

The log file will show the last successful action completed on files, and then the next thing it will show is the saving actions, initiated when I try to close the frozen Jaikoz and tell it to save my changes. There are no other error messages.

This problem is especially annoying because it usually happens in the middle of editing a large batch of files, and I don't actually want to save the tags of the ones I haven't inspected yet, since I want the option of reverting to saved.

And, no, I'm not experiencing this problem with any other programs on my Mac at this time.

Any suggestions for how to troubleshoot this? I'd like to get it worked out, because in all other ways, Jaikoz works great and I'm glad I spent the money on it.

MTA build number
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7330
Offline

Hi, sorry you are having problems.

First step is to send me your support files (advanced/Create Support Files) and some information about what time the problem occurred and what you were doing as it went wrong.

thanks Paul (Administrator)
vodsonic



Joined: 07/09/2010 14:42:13
Messages: 6
Offline

OK, I emailed you the support files, along with some further information. I experimented some more, and here's what I found: I can consistently get Jaikoz to freeze as I described in my original post by doing the following:

1. Right click on a tag field
2. Select "Set Value"
3. Hit the ESC key
4. Click "Cancel" in the "Set Value" dialog box.

It seems to be hitting the ESC key before cancelling "Set Value" that causes the problem. If I don't hit ESC, and even if I do type some other text into the dialog box before canceling, Jaikoz doesn't seem to freeze.

Maybe I just need to try to suppress my lightning-fast *cough* *cough* ancestral DOS-era ESC reflexes...
vodsonic



Joined: 07/09/2010 14:42:13
Messages: 6
Offline

And, one more thing I noticed, when I hit the ESC key during a "Set Value" again today: when the blue spinning ball appears, I can still select individual tag fields in the background, and see them highlighted, even though I can't do anything with them and the spinning ball never goes away.

I got a lot of tagging done today, because I managed to refrain from hitting the ESC key...

MTA: OK, it isn't just the escape key. It froze again when I brought up the "Set Value" dialog box, then decided against my edit, and clicked cancel. Same deal as when I hit ESC.
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7330
Offline

Ah right, its a silly bug, cancelling SetValue doesnt cancel it properly whether by pressing the cancel button or the ESC key, I'll get this fixed pronto sorry for the inconvenience

EDIT:Oh I fixed this on 30/08/2010, so will definently be in beta.

thanks Paul (Administrator)
vodsonic



Joined: 07/09/2010 14:42:13
Messages: 6
Offline

Thank you, Paul!
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7330
Offline

Fixed in new Beta http://www.jthink.net/jaikozforum/posts/list/1545.page

thanks Paul (Administrator)
 
Forum Index -> Jaikoz Issues
Go to:   
Powered by JForum 2.1.6 © JForum Team