[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Discogs Genre or Style not updated anymore  XML
Forum Index -> Jaikoz Questions
Author Message
znarb

Enthusiast

Joined: 13/07/2016 18:13:36
Messages: 11
Offline

Somehow when using the Autocorrect metadata from Discogs feature, it no longer enters values for Style in Genre (I do not want Electronic, this is also no longer deleted) Nor does it enter additional Styles in the Grouping column.

Also sometimes it enters the folder the tracks are in as Album Name.

And after resetting settings it decided to add track numbers in the file name when performing correct filename from metadata, while I clearly only specified Track - Title in settings??

https://s31.postimg.org/bi4r4vajv/Screenshot_2016_07_14_02_20_37.png
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7361
Offline

The incorrect filename from metadata problem is a known problem already fixed for the next release. Basically if you modify the mask you need to restart Jaikoz before using the mask or it will continue to use the old mask.

thanks Paul (Administrator)
znarb

Enthusiast

Joined: 13/07/2016 18:13:36
Messages: 11
Offline

Thanks Paul, do you have any idea how I can get the genre field to be filled again when updating metadata from discogs? This would be great.
I have added a link to support files https://www.dropbox.com/s/r1lpqopl9kzjcl7/JaikozSupport.zip?dl=0
and can send screenshots of my settings or anything else to verify my settings,

Thanks again.
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7361
Offline

What do yo have set for Genre on Settings:Remote Correct:Discogs

thanks Paul (Administrator)
znarb

Enthusiast

Joined: 13/07/2016 18:13:36
Messages: 11
Offline

https://www.dropbox.com/s/24q6dlb7r6leikm/Screenshot%202016-07-19%2020.53.42.png?dl=0
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7361
Offline

Ive just double checked it still works and it does for me.
I set my preferences as yours then ran Update Metadata from Discogs and they were updated, worked for both styles and genres so I'm not sure what your issue is.

thanks Paul (Administrator)
znarb

Enthusiast

Joined: 13/07/2016 18:13:36
Messages: 11
Offline

Mmm.. Strange isn't it?

Any advice on how to do a complete uninstall reinstall on OS X? As I have done this already and it clearly didn't work so there still must have been something left..
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7361
Offline

Your configuration is stored in Library:Preferences

From Finder, hold down Option Button and select Go menu

Select Library from the list

Go to Preferences : Jaikoz

Delete contents

But before you do that just try ensuring you select some songs that a value for Discogs Release Url, then empty the Genre field and run Update Metadata from Discogs and see if it adds anything to the Genre field.

thanks Paul (Administrator)
znarb

Enthusiast

Joined: 13/07/2016 18:13:36
Messages: 11
Offline

Hi,

I tried that and again today, (hoping a reboot would fix it) but no go, it doesn't fill them...
It was crazy, (this all started started after trying to change the rename mask code so track no. would be added before artist) the second field Grouping started getting the same value added as Genre too but with comma first without the space if something came before it), like:
Genre: Minimal then Grouping: ,Minimal, House, Techno which was infuriating as you can understand the obsessive need for order a music library should have like no other.. javascript:emoticon(':twisted:');

After I tried fixing that something must have gone terribly wrong somewhere.. as I'm sure I deleted the Jaikoz folder, db and caches on first uninstall..

What to do Paul?
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7361
Offline

Which did you try deleting the preferences or empty the field and running Update. Whichever one you havent tried then try that

thanks Paul (Administrator)
znarb

Enthusiast

Joined: 13/07/2016 18:13:36
Messages: 11
Offline

Both, emptying the field and running update did not re-enter the values, and if I recall correctly I did trash the preferences and other assiociated files mentioned to delete somewhere on the forum to do a clean install before doing a fresh install of Jaikoz. But I can try deleting the preferences file again, where is it located again in os x?
 
Forum Index -> Jaikoz Questions
Go to:   
Powered by JForum 2.1.6 © JForum Team