[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Blank screen when starting Jaikoz  XML
Forum Index -> Jaikoz Issues
Author Message
Zuzuzzzip



Joined: 08/08/2007 15:46:12
Messages: 3
Offline

this is more of a java problem, but i need to know on which libraries Jaikoz depends

my screen looks like this: screenie

I'm running Ubuntu Feisty Fawn amd64
I tried my 64bit java (Blackdown) and a 32bit java, but I think it's just a problem of missing libraries... (like cairo for example?)

thx in advance!
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7214
Online

Hi, Im not sure what the problem is but there are a number of possibilities.

Jaikoz requires Java 1.5.10 or later, it s only been verified with the official SUN implementation so please try that first.

It may be a permissions problem or possibly a problem with the Install Anywhere Wrapper, please try running as root and try running jaikoz.sh rather than Jaikoz. You could take a look at the jaikozdebug-0-0.log and jaikozuser0-0.log, or send them to me.

thanks Paul (Administrator)
Zuzuzzzip



Joined: 08/08/2007 15:46:12
Messages: 3
Offline

I tried to use my other java libraries /usr/lib32/java where you can select for the install...

but that didn't work..
this is what i get from running jaikoz.sh
Code:
zuzuzzzip@ZuzuPC-ubuntu:/opt/jaikoz$ sudo jaikoz.sh 
 Exception in thread "main" java.lang.UnsupportedClassVersionError: com/jthink/jaikoz/Start (Unsupported major.minor version 49.0)
         at java.lang.ClassLoader.defineClass0(Native Method)
         at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
         at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
         at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
         at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
         at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
         at java.security.AccessController.doPrivileged(Native Method)
         at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
         at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
         at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
         at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
 


my user log says
Code:
Aug 8, 2007 11:14:21 PM: INFO: Jaikoz v1.10 using Java 1.6.0 on Linux initialized successfully 
so nothing wrong here

where can i find jaikozdebug, I did a search but couldn't find it, so it's not there
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7214
Online

Zuzuzzzip wrote:
I tried to use my other java libraries /usr/lib32/java where you can select for the install...

but that didn't work..
this is what i get from running jaikoz.sh
Code:
zuzuzzzip@ZuzuPC-ubuntu:/opt/jaikoz$ sudo jaikoz.sh 
 Exception in thread "main" java.lang.UnsupportedClassVersionError: 
 

 

That shows jaikoz.sh is using an older version of Java, do java -version from the command line will tell you which version it is using

Zuzuzzzip wrote:

my user log says
Code:
Aug 8, 2007 11:14:21 PM: INFO: Jaikoz v1.10 using Java 1.6.0 on Linux initialized successfully 
so nothing wrong here
 

But that shows that when you use Jaikoz instead that it is using java 1.6 which should be ok, so probably installed ok. But did you run it as root, you need to run it as root the first time you run it.


where can i find jaikozdebug, I did a search but couldn't find it, so it's not there  

Its in the installation folder with jaikozuser0-0.log but it is only created if there is debugging information to be written so it might mot have been created.

thanks Paul (Administrator)
Zuzuzzzip



Joined: 08/08/2007 15:46:12
Messages: 3
Offline

yes I ran it as root, I've read this on the forum you had to do so the first time...

but still it does not work, oh well , it's my java though not Jaikoz itself and more likely an amd64 bit problem since there is no official Sun Java for 64-bit, I'm using Blackdown java.

Code:
zuzuzzzip@ZuzuPC-ubuntu:~$ java -version
 java version "1.4.2-02"
 Java(TM) 2 Runtime Environment, Standard Edition (build Blackdown-1.4.2-02)
 Java HotSpot(TM) 64-Bit Server VM (build Blackdown-1.4.2-02, mixed mode)

Now i checked the blackdown site, they are currently still working on 1.5, so I'll just have to wait
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7214
Online

Hi there is a version of Java for 64bit Linux available from java.sun.com download page that should be fine:

https://sdlc5e.sun.com/ECom/EComActionServlet;jsessionid=3CF3E77312DD8620633FFEB75002743C

thanks Paul (Administrator)
 
Forum Index -> Jaikoz Issues
Go to:   
Powered by JForum 2.1.6 © JForum Team