[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Increasingly seeing failure to get acoustic id  XML
Forum Index -> Jaikoz Issues
Author Message
markfaine

Pro

Joined: 10/04/2008 19:58:02
Messages: 150
Offline

It seems that more and more newly released albums are failing to get acoustic ids. Usually I can tell when it will happen because it hangs for a very long time. However, if I leave it alone long enough it will eventually report:

Code:
 Apr 4, 2011 6:17:37 PM: INFO: A new acoustic fingerprint has been
 submitted to AmpliFIND for song 1 file /home/mark/music/Britney 
 Spears/Femme Fatale/09 - Trouble For Me.flac, wait 24 hours before 
 retrieving acoustic id.
 


Guess what? There will not be an acoustic id available in 24 hours, or ever.

This has happened on three albums recenty:

The Strokes - Angles
Avril Lavigne - Goodbye Lulabye
Britney Spears - Femme Fatale

and some others I can't remember.

I don't know what is going on but I don't think it is simply a matter of no acoustic id available.

paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7208
Offline

Hmm, if it isnt available the next day it seems AmpliFIND are not processing the new fingerprints as they should be, I'll see what they have to say.

thanks Paul (Administrator)
snesbitt



Joined: 31/01/2008 12:26:52
Messages: 9
Offline

I am experiencing this as well. This is with 3.11

-steve
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7208
Offline

Had a reply, there was an issue one of their servers, should be resolved wiithin the next couple of days

thanks Paul (Administrator)
markfaine

Pro

Joined: 10/04/2008 19:58:02
Messages: 150
Offline

paultaylor wrote:
Had a reply, there was an issue one of their servers, should be resolved wiithin the next couple of days 


They had a server issue that has lasted weeks and is still ongoing? I'm not buying it. They may have had server issues but that is not the cause of this issue. I still think it is a bug of some sort. It would make sense if acoustic ids could not be generated for any file but a server outage doesn't explain why some would work and some do not.

I'm trying to debug the process locally. It looks like genpuid starts mipcore with an "fp" option and then soon after mipcore runs with an analyze option that produces output in /tmp

I've also noticed that the mipcore process hangs a lot. I sometimes have to open a shell and kill mipcore because it is running long after jaikoz has given up on ever getting an acoustic id. In fact, it appears that if I cancel the process and close Jaikoz mipcore will continue to run indefinitely until I kill it manually.

The hanging of this process can make it appear as though acoustic ids are not working for any files because if it is hung it will not allow other files to be processed.



paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7208
Offline

I thought you meant it was happening for all albums, they reported a server error to me but yes Im sure genpuid is not bug free but neither would it be any worse than a few months previous, it hasn't changed.

thanks Paul (Administrator)
gmhax



Joined: 13/04/2011 19:11:56
Messages: 4
Offline

I'm seeing a ton of these, which thankfully fail instantly:

13/04/2011 16.47.59:com.jthink.jaikoz.manipulate.musiciphelper.PUIDQuery:generatePUID:WARNING: MusicIP Error Stream:12:connect(4) failed with error 61 - Connection refusedMusicDNS servers cannot be reached right now.

However, Jaikoz issues no useful error message in the GUI, simply saying that it couldn't match 163 of 163 songs (or whatever).
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7208
Offline

Are you still getting that ?

thanks Paul (Administrator)
gmhax



Joined: 13/04/2011 19:11:56
Messages: 4
Offline

When I tried some musicbrainz fingerprinting the other day it worked.

However, I've told it to use up to 4 CPUs on OS X and mipscore was instead running 4 threads on 1 CPU, yielding no performance improvement.
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7208
Offline

Thats wierd, can you see if there was 1 or 4 genpuid processes ?

thanks Paul (Administrator)
gmhax



Joined: 13/04/2011 19:11:56
Messages: 4
Offline

One genpuid process with 3 threads, one mipcore process with 4 threads using 100% CPU. However, best I can tell, those 4 threads are executing on one core -- it should be using 400% CPU, not 100%.

Also, while mipcore is cranking away, my load average never goes above 2.5 or so, and this on a busy desktop system running a ton of stuff. If mipcore were pegging the CPU I'd expect to see load above 4.

I updated to 4.1.0 NGS before re-testing this.
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7208
Offline

Okay, in the near future we are going to move to a new fingerprinting system called http://acoustid.org/ . This has a number of advantages, one of them being the fingerprints can be created locally without accessing the fingerprint server. So this problem will resolve itself.

The only problem with Acoustid at the moment is that it database is not as large as the AmpliFIND one, so please help by submitting your fixed songs using Action/Remote Correct/Submit Musicbrainz/AcoustId Pair.

thanks Paul (Administrator)
gmhax



Joined: 13/04/2011 19:11:56
Messages: 4
Offline

I'll VNC home and submit my entire collection now!
 
Forum Index -> Jaikoz Issues
Go to:   
Powered by JForum 2.1.6 © JForum Team