[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Several small (workaroudable) problems with Linux  XML
Forum Index -> Jaikoz Issues
Author Message

I got Jaiko working on my Linux (Ubuntu "edgy" 6.10, Sun's JRE 1.5).

Here are the gotchas (I hope some developper will look at them, they are easy to fix) :

- LaunchAnywhere bugs when we have a non-C, non-US environment and a shell prompt setted.
" An internal LaunchAnywhere application error has occured and this application cannot proceed. (LAX)" (plus java backtrace complaining about an unicode problem).
Workaround : type "unset PS1 ; unset TITLEBAR", and relaunch the installer.
Would be nice to add this "unset PS1; unset TITLEBAR" in jaiko.bin shell script part...

- The /usr/bin/jaiko.sh script has windows (not unix) line ending (that is, with \r). So bash can't execute this script.
Workaround: sudo perl -pi -e 's/\r//g' /usr/bin/jaiko.sh
I hope that jaiko's devs will remove those windows EOL in next versions (and be more carefull when editing unix shell scripts under windows).

- When launched, jaiko tries to write logs in the current path. But this one is not always writable by the user, and in this case, the logger crashes.
Jaiko should rather write logs in the users home directory (and handle logging problems more gracefully).


Joined: 21/08/2006 09:21:27
Messages: 7274

Thanks for the info, will sort this out for next release

thanks Paul (Administrator)
Forum Index -> Jaikoz Issues
Go to:   
Powered by JForum 2.1.6 © JForum Team