[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Upgrading to Java 1.6.0_02 in Ubuntu Feisty Fawn  XML
Forum Index -> Jaikoz Issues
Author Message
ifrit


[Avatar]

Joined: 10/03/2008 17:07:20
Messages: 3
Offline

Hi,

I follow all the steps and when I do Code:
$ sudo ./jaikoz-install.sh
I get Code:
The application that you are trying to install requires a 1.6.0_02 version or later of the Java platform.
 You are running a 1.6.0 version of the Java platform.

Then I go to the Synaptic to upgrade and I still the same version

How I can upgrade?

Thanks!

I really want to try Jaikoz!
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7347
Offline

Can you try Code:
java -version
as both your normal user and root user to check that both are using the correct version of java, as it appears not.

thanks Paul (Administrator)
ifrit


[Avatar]

Joined: 10/03/2008 17:07:20
Messages: 3
Offline

Hi, paultaylor!

Thanks for you answer

I write $ java -version and I get Code:
java version "1.6.0"
 Java(TM) SE Runtime Environment (build 1.6.0-b105)
 Java HotSpot(TM) Client VM (build 1.6.0-b105, mixed mode, sharing)


I write $ sudo java -version and I get Code:
java version "1.6.0"
 Java(TM) SE Runtime Environment (build 1.6.0-b105)
 Java HotSpot(TM) Client VM (build 1.6.0-b105, mixed mode, sharing)


paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7347
Offline

Ok the answer is self evident you have Java 1.6.0 installed but you need at least 1.6.0_02. Please get the latest version from java.sun.com and try again.

thanks Paul (Administrator)
ifrit


[Avatar]

Joined: 10/03/2008 17:07:20
Messages: 3
Offline

Hi, paultaylor!

I'm sorry, but i'm quiet clumsy today... could you give me the direct link?

Sorry for disturb with this not specific issues.

Thanks!
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7347
Offline

Hi select Linux-self extracting zip on this page http://www.java.com/en/download/manual.jsp

thanks Paul (Administrator)
smika



Joined: 07/06/2007 13:27:24
Messages: 9
Offline

I solve the problem. I add the sid repository to my sources.list. I updated Java and remove the repository.



Today I change from Kubuntu Gutsy to Debian Lenny. I have the same issue, So i get an error when i want to install jaikoz. I need version 1.6.0_02, but i have 1.6.0. but when the result in de konsole are:

debian-laptop:~# java -version
java version "1.6.0_05"
Java(TM) SE Runtime Environment (build 1.6.0_05-b13)
Java HotSpot(TM) Client VM (build 10.0-b19, mixed mode, sharing)
debian-laptop:~# whereis java
java: /usr/bin/java /etc/java /usr/share/java /usr/share/man/man1/java.1.gz
debian-laptop:~#

What I am doing wrong?

Thanks,

Smika
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7347
Offline

Im confused, have you still got a problem or have you fixed it ?

thanks Paul (Administrator)
smika



Joined: 07/06/2007 13:27:24
Messages: 9
Offline

I solved it. But i thought there will be an edit dat on my post when I edit it.
vanchuck



Joined: 17/05/2008 14:41:19
Messages: 1
Offline

Hi there, I am also having this problem, but with the latest version of (K)Ubuntu, 8.04 Hardy Heron:

Code:
 dave@antares:~/Desktop/jaikoz-linux$ ./jaikoz-install.sh
 The application that you are trying to install requires a 1.6.0_02 version or later of the Java platform.
 You are running a 1.6.0 version of the Java platform.
 Please upgrade to a newer version.
 dave@antares:~/Desktop/jaikoz-linux$ whereis java
 java: /usr/bin/java /etc/java /usr/lib/java /usr/lib64/java /usr/share/java /usr/share/man/man1/java.1.gz
 dave@antares:~/Desktop/jaikoz-linux$ /usr/bin/java -version
 java version "1.6.0"
 OpenJDK  Runtime Environment (build 1.6.0-b09)
 OpenJDK 64-Bit Server VM (build 1.6.0-b09, mixed mode)
 


I tried switching to testing (Intrepid) repositories and updating, but the version number did not change and the result was the same.

It seems I'm running 1.6 beta 9, the only newer version on the sun webpage is 1.6 beta 10...

Any ideas? Is there anyone else who has managed to get jaikoz to work on recent builds of java and debian/ubuntu releases?
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7347
Offline

Hi no, there are four levels - you running 1.6.0_0 build 9 you need 1.6.0_2 , the beta you are referring to is 1.6.0_10 . Get the elatest one from Sun and should be ok.

thanks Paul (Administrator)
 
Forum Index -> Jaikoz Issues
Go to:   
Powered by JForum 2.1.6 © JForum Team