[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Files not saving correctly? Empty fields. (SOLVED)  XML
Forum Index -> Jaikoz Issues
Author Message
dkoh

Pro
[Avatar]

Joined: 05/06/2010 15:02:29
Messages: 246
Location: NorCal, US
Offline

This always happened once in a while, but I always blamed it on W7 crappy file caching, or editing fields with the AC running (older Jaikoz), etc. and just ignored it. Looking back through stuff I'm finding it much more pronounced.

On the initial filing/saving, everything is populated correctly. Save, close and reopen and fields will be missing like shown. Sometimes I can go through this cycle up to four times before things seem to stick. I've tried 'Force Save' before editing, like maybe it's an older ID3 that won't support new tags, but it doesn't seem to make a difference.

The only correlation I see is the ID3 version. This seems to change even if it's a rip from FLAC or CD where all files started as the same version.

Prefs>Save:
ID3Tag V1: Write if tag exists
ID3Tag V2:
-Always write tag
-v23
-ISO-8859-1
-ISO-8859-1
-UTF-8
-Save Existing fields using these... (checked)
Compatibility:
-Do not unsynchronize (checked)
-Windows Media Player
iTunes Autoupdate
-(nothing checked)




Ideas?

-----------------------------------
Windows 7 64-bit
Asus M4A88TD-V EVO/USB3
AMD AthlonII X3 3.20 GHz
8.0GB RAM
Nvidia 8800 GTX
Back to 5.1.1 NGS (320 & FLAC)
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7486
Offline

Sorry, what is the screenshot meant to be showing me ?

thanks Paul (Administrator)
dkoh

Pro
[Avatar]

Joined: 05/06/2010 15:02:29
Messages: 246
Location: NorCal, US
Offline

This is what it looks like when I reopened these files (in this case the third time) after already fixing and saving everything. The incomplete records looked like the other populated ones on last save, but for some reason some fields don't take. It's always the same tags too - the ones you see missing (ie. I never see Title missing).

Sometimes there's 80% of an entire artist missing, sometimes it's one record in 100.

This is on a local disk, BTW.

-----------------------------------
Windows 7 64-bit
Asus M4A88TD-V EVO/USB3
AMD AthlonII X3 3.20 GHz
8.0GB RAM
Nvidia 8800 GTX
Back to 5.1.1 NGS (320 & FLAC)
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7486
Offline

I don't see the problem, I wonder if you realize that the bottom tab is showing the ID3 fields not the main Edit fields.

Copyright Info, Encode By, Software Hardware and Payment Url are not fields that get automatically populated by matching to MusicBrainz/Discogs.

thanks Paul (Administrator)
dkoh

Pro
[Avatar]

Joined: 05/06/2010 15:02:29
Messages: 246
Location: NorCal, US
Offline

In the top image, records 0, 2, 3, 9, 12 & 13 are missing some tags, like Total Tracks & Genre (or at least not all 3 genres). These have already been saved twice, but still came up empty. If I fill them back in, save and close, there is a chance they come in blank when I open them again.

In the bottom image, these same records with empty fields have ID3v1v23 instead of ID3v23. I don't know if this is a correlation or is just a symptom of the same problem, just something I found noteworthy and may be informative.

You see now?

-----------------------------------
Windows 7 64-bit
Asus M4A88TD-V EVO/USB3
AMD AthlonII X3 3.20 GHz
8.0GB RAM
Nvidia 8800 GTX
Back to 5.1.1 NGS (320 & FLAC)
dkoh

Pro
[Avatar]

Joined: 05/06/2010 15:02:29
Messages: 246
Location: NorCal, US
Offline

I finally found it! And it's not Jaikoz, It's TagRunner.

I tried every possible combination of commands in Jaikoz and couldn't reproduce the problem. Until I dropped them in TagRunner (what I use for lyrics) and almost slapped myself out of the chair. Let TagRunner find and save, open them back up in Jaikoz, and the missing fields came back only on records with lyrics.


-----------------------------------
Windows 7 64-bit
Asus M4A88TD-V EVO/USB3
AMD AthlonII X3 3.20 GHz
8.0GB RAM
Nvidia 8800 GTX
Back to 5.1.1 NGS (320 & FLAC)
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7486
Offline

Good detective work !

I wonder why TagRunner is doing that, (and I wonder where it gets its lyrics from) , please raise an issue with TagRunner.

thanks Paul (Administrator)
dkoh

Pro
[Avatar]

Joined: 05/06/2010 15:02:29
Messages: 246
Location: NorCal, US
Offline

These are the sources listed in TagRunner, with the majority of matches coming from AstraLyrics:

AstraLyrics
LyricsDemon
LyricsFreak
LyricsOnDemand

As far as support, Audials has moved to large (expensive) audio suites and TagRunner had been abandoned long ago. They have a pretty crappy track record anyways, so I guess I'll just put batch-lyrics on hold in the meantime.

-----------------------------------
Windows 7 64-bit
Asus M4A88TD-V EVO/USB3
AMD AthlonII X3 3.20 GHz
8.0GB RAM
Nvidia 8800 GTX
Back to 5.1.1 NGS (320 & FLAC)
 
Forum Index -> Jaikoz Issues
Go to:   
Powered by JForum 2.1.6 © JForum Team