[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Reports taking extremely long time to generate  XML
Forum Index -> Jaikoz Issues
Author Message
greengeek

Pro
[Avatar]

Joined: 18/09/2007 02:50:48
Messages: 435
Offline

I just installed the latest version of jaikoz. I was using one that was 4 versions older previously. 5.6 or so I think. I decided to try it with using the musicbrainz server instead of my local server as I did not have it up and running. I noticed in this new one that the reports are taking a very long time to generate.

For example, if I load just 75 albums, all are compilation albums, and 24 of them have release mbids. I run the report to see if I am missing any tracks. The "Creating List of Missing Songs..." window comes up and the progress bar goes to the end fairly quickly, in under 30 seconds, as it counts through the albums processed so far. However then it just stops at that window once the progress bar hits the end.

The console window however shows that jaikoz is still busy at work what appears to be doing musicbrainz api look ups once every 1 second for each artist tied to a song. Being that these are various artists compilations with 100 songs / 100 artists per album, this is taking an extremely long time. No errors are being thrown. Just a Decoded api url message with time stamp every one second for artist including aliases tags.

I don't recall seeing this in the previous versions. Is this something new?

KevinBluemel.com
Contemporary Instrumental Musician and Composer. Stop by to listen, watch videos, and get free downloads of songs and sheet music.
[WWW]
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7299
Offline

Hmm, nothing has changed in this area recently AFAIK but I'll take a look.

thanks Paul (Administrator)
 
Forum Index -> Jaikoz Issues
Go to:   
Powered by JForum 2.1.6 © JForum Team