[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Jaikoz 1.8 released on April 17th 2007  XML
Forum Index -> Jaikoz Announcements
Author Message
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7556
Offline

Released today, this latest version of Jaikoz now contains a Browser (similar to the Browser in iTunes) to make it easier to filter your loaded audio, and performs tasks on subsets of your data. There also a number of smaller enhancements and fixes, full details at http://www.jthink.net/jaikoz/jsp/news/start.jsp

thanks Paul (Administrator)
cpicton

Enthusiast

Joined: 23/03/2007 02:47:00
Messages: 12
Offline

It looks like some text replacement is not being done correctly...

I am getting lots of %1 where I should be getting actual number or filenames:

Example:

Code:
 %1 Files to have acoustis Ids retrieved
 %1 Files processed so far
 

paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7556
Offline

cpicton wrote:
It looks like some text replacement is not being done correctly...

I am getting lots of %1 where I should be getting actual number or filenames:

Example:

Code:
 %1 Files to have acoustis Ids retrieved
 %1 Files processed so far
 

 

Is this happening in the progress dialog ? I havent been able to replicate this problem myself, it all appears to be working fine.

thanks Paul (Administrator)
cpicton

Enthusiast

Joined: 23/03/2007 02:47:00
Messages: 12
Offline

This is happening in many places - progress dialog, output window, jaikoz user log, etc

Examples:

Apr 23, 2007 10:18:12 PM: WARNING: Unable to retrieve an acoustic id for %1 because this track cannot be analysed

But not for everything:

Apr 24, 2007 5:14:49 AM: SEVERE: There was a problem submitting a query to MusicBrainz for Record Number 146 with filename Weird Al Yankovic - Another One Rides The Bus.mp3




paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7556
Offline

cpicton wrote:

Apr 23, 2007 10:18:12 PM: WARNING: Unable to retrieve an acoustic id for %1 because this track cannot be analysed
 

Chris, in previous versions of Jaikoz there were two different replace text tokens used in the language properties file {0} and %1, this has now been rationalised in Jaikoz 1.8 so that there is only one ({0}), but you seem to be picking up old ones. I cant remember what operating system you ar eusing but everything seems in order.

Could you check that your jaikoz.properties file contains no %1's and that your jaikoz_en.properties file exists but is empty.

If neither of these statements is true there may be an installation problem, please uninstall, delete the installation folder, and reinstall to see if the problem persists and let me know.



thanks Paul (Administrator)
cpicton

Enthusiast

Joined: 23/03/2007 02:47:00
Messages: 12
Offline

paultaylor wrote:
Could you check that your jaikoz.properties file contains no %1's and that your jaikoz_en.properties file exists but is empty. 


I cleared out jaikoz_en.properties, and the problem has gone away

Thanks
paultaylor

Pro
[Avatar]

Joined: 21/08/2006 09:21:27
Messages: 7556
Offline

cpicton wrote:

I cleared out jaikoz_en.properties, and the problem has gone away
 

Thats good, it seems there was some kind of installation problem, but not sure how, Im not sure what operating system you are on but I havent been able to reproduce it.

thanks Paul (Administrator)
 
Forum Index -> Jaikoz Announcements
Go to:   
Powered by JForum 2.1.6 © JForum Team