[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Messages posted by: arby  XML
Profile for arby -> Messages posted by arby [25]
Author Message
I want to enter multiple values into the 'Artists' field.

E.g.
Code:
     John Doe; Jane Deer
 

But if I use that ^sytax, what shows in the 'Artist' column of the ColumnBrowser is a single, consolidated entry:
Code:
     John Doe; Jane Deer
 

What syntax do I need to use in the 'Artists' field,
Code:
     John Doe (some delimiter?) Jane Deer
 

so that I get *TWO*, separate entries in the 'Artist' browser column,
Code:
     John Doe
     Jane Deer
 

?

paultaylor wrote:
Sorry not possible currently, but it should be possible quite soon when I unencode the preferences files, something Ive wanted to do for a while. 


Has this been implemented?

To fend off the nightmare of dealing with an ever-increasing # of "sub-sub-sub-sub-sub-...-genres" , I've a list of ~20 genres that I wish to use for my own uses.

That list -- and ONLY that list -- is what I'd like to see in the Genre dropdown.

If it's "in here", I haven't found it yet.
I've upgraded to

Code:
 Jaikoz 9.3.0 NGS
 Build Version: 1162
 Build Date: 19 October 2017
 


on Linux/64.

I'm processing a bunch of songs to OGG, as I always do ...

I always used to have output as

Code:
 BASE_FOLDER/ARTIST/ALBUM/SONG(FILENAME).ogg
 


Now, however, SUBFOLDER's no longer a nested path, but just replicating the FILENAME. So, e.g.,

Code:
 Base Folder  /home/media/ogg
 Sub Folder   A_Winter's_Tale
 Filename     10_-_A_Winter's_Tale.ogg
 


Has some required scripting changed?
I have an existing, already-processed-by-Jaikoz hierarchy of folders+subfolders & mp3 files.

Atm, filenames & dirnames have spaces in them.

I want to replace ALL spaces with underscores, "_".

I added a

" " -> "_" item to my current, enabled WordReplacer manipulator.

I'm unable to get any 'action' to write those changes to either dir- or file-names.

How do I "apply" the added manipulatpr rule, replacing " " with "_"?

paultaylor wrote:
Collections, essentially allow you to say I have these releases, and share that information with others or not. Only the MusicBrainz release ids are stored, nothing else so Im not sure if this is what you mean by 'known good' data. 


Hm. Thanks for the clarification.

No, I meant -- and hoped for -- more that just the releaseIDs.

For *many* of my Albums, whether matched by AcoustID, MB data (bar code, best match, etc), DiscOgs, etc, the Album data, and sometime some-not-all song data, is flat out wrong.

I was hoping there's a way to upload/update that data "somewhere" (thinking MB was 'the place') so that "my" Jaikoz can pull/update preferentially from "my" data.

Iiuc, the best source of that "known good" data is, simply, my local Jaikoz data.

paultaylor wrote:
1> Agree I'll update the documentation, although when I added this function it was very much a niche function for MusicBrainz users rather than a core function of the Jaikoz tagger - I haven't devoted much time to this. There isn't currently a facility in webservice to allow an external application to create a collection you have to do it via the MusicBrainz website.

2> I just tried deleting any collections I had and rerun Add Collections and for me it displays an empty list, so of course it shouldn't just freeze, but you are the only one to ever have reported this. 


Thanks.

Iiuc, adding my Jaikoz-corrected collections TO MB can (does?) expose/share that data to MB for others to use.

I assume that, at least, my MB data is available to ME, using Jaikoz, to update my local data from.

Imo, that's hugely valuable -- even if only for my private collection -- to store/recover "known good" data. To noones surprise, lots of MB, and others', data is ... less than robust.

Again, this 'freeze' if no MB collection is 100% reproducible. Here. If there's any further data/diagnostic that'd be helpful, please let me know.

paultaylor wrote:
No, I mean have you created a collection within Musicbrainz.

i.e login to Musicbrainz website
Go to My Data/My Collections
Click on Create New Collection
Enter name then create Collection. 


No, I did not. I assumed, apparently incorrectly, that Jaikoz would create the Collection.

@ MB, I created, now, a "test" collection.

@ Jaikoz, "Add to MB collection" now DOES pop up the dialog, list "test".

Adding music from Jaikoz TO that selected collection now works as expected.

So it appears that:

(1) documentation for dummies that states "Create a/the collection first @ MB"
&/or
(2) Error handling to avoid app freeze in the case/instance that no collection @ MB exists

are called for.
If by "Musicbrainz Collection" you mean, e.g., albums "in Jaikoz" that have been populated from Musicbrainz, then yes -- many.

Trying to add-collection TO musicbrainz is what's failing/crashing.

When you select Add to Collection does a dialog appear whereby you select the collection you want to add your songs to or not.
 

No dialog. Just a small, empty, grey rectangle

See the attached snapshot: "Jaikoz_AddToMBColl_Fail.png"

Have you retried this, does it always happen even with different songs
 

Yes. It's fully reproducible -- happens with any/every song.

Please retry and it it fails email support@jthink.net your complete support files (Advanced/Create Support Files)
 

Will do ...

paultaylor wrote:
Does it work if instead of using the symbolic link you use the real path. 


Unfortunately, no.

Using the link-path or the real-path, the result's the same -- the file dialog opens @ /home/arby

paultaylor wrote:
So you have General:Save:Move Folder set to

Code:
/home/arby/Media/Music.RE-tagged

 


yes

paultaylor wrote:
Yet the folder dialog always opens to

Code:
/home/arby/

 


yes

paultaylor wrote:
Please double check this is the case 


both verified

paultaylor wrote:
and the folder
/home/arby/Media/Music.RE-tagged exists
 


it does. right next to "Music"
Code:
 ls -al /home/arby/Media/Music*
   lrwxrwxrwx 1 arby users 40 Feb 11 18:34 /home/arby/Media/Music -> /mnt/NFS4/MEDIA_SVR/Music/
   lrwxrwxrwx 1 arby users 40 Feb 15 08:43 /home/arby/Media/Music.RE-tagged -> /mnt/NFS4/MEDIA_SVR/Music.RE-tagged/
 
 ls -ald /mnt/NFS4/SYN_HOME_SHARE/Music*
   drwxr-xr-x 103 arby users  20K Feb 20 14:10 /mnt/NFS4/MEDIA_SVR/Music/
   drwxr-xr-x   2 arby users 4.0K Feb 15 16:59 /mnt/NFS4/MEDIA_SVR/Music.RE-tagged/
 

Thanks for the clarification.

So, iiuc, when I "Save and move" it should move all to the pre-defined "Move folder" ?

Atm, even with the "Move folder" defined in prefs, on "Save & Move", a selection dialog is opened to location == "/home/myuser", and i have to nav to the target folder on each & every save.

How do I auto-move to the predefined folder when I select "Save and Move"?

Perhaps I've misunderstood ...

when I run Autocorrector, sometimes-not-always the returned match is to a listing on "Vinyl" media.

when I check a manual correction listing, the CD media listing IS there -- but not initially selected.

i've selected the Prefs' "prefer CD" media option -- but is there a ALWAYS use the CD media listing option?

I've a music collection in: /home/arby/Media/Music

I want to Load from that location, use Jaikoz to make changes/corrections, then Save to a new location.

To that end, I've set in Jaikoz' prefs,

Code:
 Preferences -> General -> Base folder
 	/home/arby/Media/Music.RE-tagged
 


and

Code:
 General -> Default Read Folder
 	/home/arby/Media/Music
 [X] Load Fromd this Folder on Startup
 


and

Code:
 Preferences -> Save -> General -> Move folder
 	/home/arby/Media/Music.RE-tagged
 [X] move associated files
 



As expected, on Jaikoz startup all music in my collection is loaded.

BUT, if in Edit window I select an album's songs, make corrections etc, then click "Save" ... the changes are saved BACK to the originally read

Code:
 /home/arby/Media/Music
 


folder, instead of the targeted/desired

Code:
 /home/arby/Media/Music.RE-tagged
 


folder.

Is this the correct setup/config for saving selected changes to a *new* folder path?

paultaylor wrote:
But sounds like there is an error with the KDE shortcut, please raise an issue. 


http://jthink.net:8081/browse/JAIKOZ-591

thanks.

paultaylor wrote:
No problem, just logging requests made to MusicBrainz to help me determine problems- I concede it is confusing but SEVERE in logger parlance just means highest priority logging that should always be displayed as opposed to INFO which is less important or even FINEST which is even less.  


ah. not clear which "parlance" you're referring to -- @ app, or @ OS -- but, fwiw, 'SEVERE' and 'FINEST' are not typical log-levels for linux logging. "DEBUG" would be common usage (http://www.kernel.org/doc/man-pages/online/pages/man2/syslog.2.html).

in any case, got it.

paultaylor wrote:
But these should should get written to a log not console, how are you starting Jaikoz ?  


I'm using the Jaikoz-created KDE menu-item, currently in the Launcher Menu tree @

Launcher Menu -> Multimedia -> Media Editing -> Jaikoz Audio Tagger -> Jaikoz

which contains:
Code:
 	General:
 		Name: Jaikoz
 		Description:
 		Comment: Jaikoz Audio Tagger
 		Command: sh "/usr/local/Jaikoz/jaikoz.sh"
 		[X] Enable launch feedback
 		[ ] Place in system tray
 		[ ] Only show in KDE
 		[ ] Hidden entry
 	Advanced
 		Work path: /usr/local/Jaikoz
 		[ ] Run in terminal
 		[ ] Run as different user
 


When I select the menu item from the Launcher Menu, a shell@Konsole opens, and the Jaikoz app is launched.

While the Jaikoz app is running in the GUI, output continues to flow @ the shell.

Having the shell open is an annoyance, but not a problem, really. I haven't yet bothered to figure out WHY the shell opens in the 1st place.
i've 5.1.1 installed.

i've imported a music collection, and exec'd an "Auto Correct from Music Brainz".

it seems to be progressing -- data's being changed and highlighted in the GUI -- but the shell output displays a constant stream of "SEVERE" messages,

...
20/02/2013 06.15.20:com.jthink.jaikoz.manipulate.musicbrainzhelper.MusicBrainzServerQuery:doQuery:SEVERE: 06:15:20:361:URL Decoded:http://musicbrainz.org/ws/2/recording/167701ea-48be-44c9-8fe7-d5963e28f114?inc=releases media artists
20/02/2013 06.15.21:com.jthink.jaikoz.manipulate.musicbrainzhelper.MusicBrainzServerQuery:doQuery:SEVERE: 06:15:21:361:URL Decoded:http://musicbrainz.org/ws/2/artist/fbaba2b0-3a6f-41b1-9ecd-f89c1a666e99?inc=aliases tags
20/02/2013 06.15.22:com.jthink.jaikoz.manipulate.musicbrainzhelper.MusicBrainzServerQuery:doQuery:SEVERE: 06:15:22:362:URL Decoded:http://musicbrainz.org/ws/2/recording/c5f1924e-cf40-4657-b30e-1ff9c7ac7b98?inc=releases media artists
20/02/2013 06.15.23:com.jthink.jaikoz.manipulate.musicbrainzhelper.MusicBrainzServerQuery:doQuery:SEVERE: 06:15:23:362:URL Decoded:http://musicbrainz.org/ws/2/recording/16df6e9d-33a5-41a3-8349-0bddb615613c?inc=releases media artists
20/02/2013 06.15.24:com.jthink.jaikoz.manipulate.musicbrainzhelper.MusicBrainzServerQuery:doQuery:SEVERE: 06:15:24:362:URL Decoded:http://musicbrainz.org/ws/2/release/07338e83-b752-448e-833f-eb3ec7b5abff?inc=media url-rels labels recordings release-groups artist-rels artist-credits discids tags isrcs recording-rels recording-level-rels work-level-rels release-rels label-rels
...

it doesn't explicitly state these are errors, but SEVERE doesn't appear to be good.

what's the meaning of these "SEVERE" messages, and what, if anything, can/should be done to fix it?

thanks.
fyi,

http://jthink.net:8081/browse/JAIKOZ-587

thanks.
ok.

is this "Issues" forum where you'd like to see "bug reports", or do you have a bugtracker somewhere?

any specific further info you need for this issue? happy to provide as needed/requested.

thanks.

EDIT:

I found the JIRA issue tracker. Unfortunately, when I try to register an account there (@ http://jthink.net:8081/secure/Signup!default.jspa), I get the following error message:

"Sign up
You cannot sign up at this time, as the user limit for JIRA has been exceeded. For further assistance, please contact your JIRA administrators."
 


paultaylor wrote:
Yes, maybe although unless you loaded as a playlist Jaikoz couldnt hope to know the song is in a playlist, 


Not asking for any 'intelligence', only the option to create per-album/per-directory playlists

(1) select a folder of music for a given CD/album
(2) generate a playlist for that specific folder/album, named (e.g.) "Artist-Album.m3u" (perhaps defined by a filter)
(3) save the playlist to the collection's BASE folder

, nothing more.

paultaylor wrote:
creating playlists does seem a bit out of scope for a tagger. 


depedns. it's a matter of perspective. 4 functions necesary to manage/use a collection

-- 'ripper' rips sources to tracks
-- 'transcoder' (often 'in' ripper) transcodes tracks
-- 'player' plays collections, manages dynamic/multialbum/extended playlists
-- 'tagger' organizes and prepares the music collection to be used/played in/on a player -- including correcting metatags, filde/folder paths, cover art file generation (all of which Jaikoz does now), and 1-per-directory playlists

as Jaikoz can correct/change both folder- & file-names, per-track as well as via mass-tagging, any existing m3u playlists can end up incorrect.

nice-to-have the ability to (re)generate playlists, in the BASE folder, when changes are made to folder-/file-name metadata.

thanks
hi,

i've just started using JaikozPro, and am plugging away at my music collection, correcting just about everything.

my original rips were done with K3B on linux, and the created .m3u playlists are -- after folder/file correction & move by Jaikoz -- no longer correct.

i've seen some old mention in forums re: direct m3u creation (not yet doable in 2010), and lots of iTunes playlist discussion.

how's one correct/delete old & outdated playlists, and (re)create new m3u playlists using Jaikoz if not an iTunes user? my collection is all *.ogg, and my players are !apple -- USB-mountable Android devices, linux media servers, & Sansa Fuze+.

thanks!
Hi,

I've corrected a bunch of info locally using JaikozPro for a Multi-disc collection.

I'd like to now add the correct(ed) collection data to my registered-user's Musicbrainz Collection feature to upload a list of your Music Collection.

To do that I select:

Action -> Remote Correct -> Add to your MusicBrainz Collection

@ exec of that select, Jaikoz freezes completely. To exit/recover, I have to `kill -9` the Jaikoz proc.

On freeze, the logs contain:

Code:
 ==> jaikozuser0-0.log <==
 Feb 16, 2013 10:00:07 AM: INFO: Started to save changes to all modified songs
 Feb 16, 2013 10:00:07 AM: INFO: Did not save 29 files because they were not modified or marked for deletion
 Feb 16, 2013 10:00:07 AM: INFO: Completed saving of 0 songs
 Feb 16, 2013 10:00:07 AM: INFO: Completed deletion of 0 songs
 
 ==> jaikozdebug0-0.log <==
 16/02/2013 10.00.07:com.jthink.jaikoz.indexed.DataIndexer:reindex:SEVERE: Reindex start:Sat Feb 16 10:00:07 PST 2013
 16/02/2013 10.00.08:com.jthink.jaikoz.indexed.DataIndexer:reindex:SEVERE: Reindex end:Sat Feb 16 10:00:08 PST 2013
 


Known issue, or any hints?

Thanks.

paultaylor wrote:


Choose a good font for everything
 

Hmm, I havent a clue what a good font would be, I thought the fonts were anti-aliased on everything now
 


I'm running JaikozPro 5.11 on linux/64 (Opensuse 12.2 + KDE 4.10).

The fonts used/displayed are too small/grainy for my tired old eyes.

In a naive attempt to remedy that, being a java app (swing? dunno yet ...), I modified jaikoz.sh to invoke:

Code:
java -Xms150m -Xmx800m -XX:MaxPermSize=200m -splash:splash.png -jar lib/jaikoz.jar -l2 -m2 -f -Dswing.aatext=true -Dawt.useSystemAAFontSettings=on


where the additional

Code:
-Dswing.aatext=true -Dawt.useSystemAAFontSettings=on


is what I use, successfully, to get other Java apps (e.g., Eclipse) to use my System fonts.

Unfortuantely, it seems to make no difference :-/

What, if anything, is the right/available method for convincing Jaikoz to use System fonts?

rmgarnett wrote:
Equivalently, the user could click the column sort button for album, then by track number. Making the sort stable (according to the previous ordering, NOT the record number) gives the users the expected behavior and makes implementing a GUI multicolumn sort trivial for the implementor. 


Iiuc, this request addresses the option to sort a displayed selection of tunes in Jaikoz on multiple columns, e.g.

1st by Disc #
2nd by Track #

Does this simple capability exist (yet) in the GUI? If it's in here, I've missed it so far ...

Thanks
 
Profile for arby -> Messages posted by arby [25]
Go to:   
Powered by JForum 2.1.6 © JForum Team