[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Messages posted by: pped  XML
Profile for pped -> Messages posted by pped [14]
Author Message
I have now established that the incompatibility is created by using the QNAP Upload utility to copy a ripped CD from my hard disk to the QNAP disk.

After this upload Jaikoz will give an error message when attempting to read tracks with non-English characters.

If I rip directly to the QNAP drive or use the Mac Finder to copy files then there is no issue.
Hi Paul and All,

Just to close the loop on this topic, my final observations in case they can be helpful for others.

In the end it does not seem to be an access problem but rather an issue with incompatible code sets. I can browse all the flawed files directly on the QNAP (via the browser interface), they look correct, they are identified as FLAC files and they can even be replayed.

Some of them look fine in Kinsky and can be played. Others do not show up in Kinsky, and in the Mac Finder they are displayed as Unix executable files. These are the files that Jaikoz will not load. Common for all of them is that they contain non-English characters from Scandinavian, German, French or Spanish language (e.g. the German operas).

This may be because some CDs were ripped with Western code set rather than Unicode, or it may have happened during the moving/uploading process. Or it may be for another reason. I really can't tell and with OS X, Unix, Jaikoz and Kinsky in the mix many potential reasons could be investigated.

Fortunately the number of albums is manageable (maybe 50) so I have given up finding out the reasons and settled on the solution. If I have the discs I delete and reload. If not I will edit the file names via the QNAP interface to replace non-English characters. So far this has worked for all the files I have attempted to repair.
Adding a bit more detail in case anyone else runs into the same. The issue seems to be because of non-english characters in album or track names, such as German umlaut (ä, ö, ü.... that kinda stuff).

It seems that when the CD's are ripped with XLD some magic is applied to ensure these characters are readable and displayable by OS X Finder, Jaikoz, etc. Since the rip I have moved and copied folders around to get a better structure. Those folder processes appear to have corrupted the magic that makes non-English characters readable in OS X Finder etc. I think it is a OS X issue because I am sure it was also present before my move to QNAP. I just ignored it at that time because it was not a problem.

Since I now could neither rename the files in OS X Finder nor repair the metadata in Jaikoz I instead needed to access the folders from a MS Windows computer. This made it possible to rename the files and then repair the metadata with Jaikoz.

Thanks to Paul for help with identifying the issue. We now just need to figure out what the issue is with the unrecognisable FLAC files. It may be that it is a similar kind of problem.
Email sent as requested. As stated in the mail these folders are on a QNAP NAS. I am really sorry I forgot to mention that.
Thanks again, I really appreciate you taking the time. I tried again, still without any luck.

Both before and after the list of privileges look as follows:

pers-mac-mini:~ perpedersen$ ls -l /volumes/multimedia/mymusic
total 352
drwx------ 1 perpedersen staff 16384 5 Nov 21:18 Folder Artists A to E
drwx------ 1 perpedersen staff 16384 5 Nov 11:03 Folder Artists F to J
drwx------ 1 perpedersen staff 16384 5 Nov 12:32 Folder Artists K to O
drwx------ 1 perpedersen staff 16384 5 Nov 14:35 Folder Artists P to U
drwx------ 1 perpedersen staff 16384 5 Nov 19:35 Folder Artists V to rest
drwx------ 1 perpedersen staff 16384 4 Nov 23:50 Folder Classical Music
drwx------ 1 perpedersen staff 16384 5 Nov 04:24 Folder Classical Opera
drwx------ 1 perpedersen staff 16384 12 Nov 19:52 Folder Jazz Music
drwx------ 1 perpedersen staff 16384 5 Nov 20:57 KMSC HD Music
drwx------ 1 perpedersen staff 16384 5 Nov 20:33 KMSC Ripped CDs
drwx------ 1 perpedersen staff 16384 5 Nov 20:54 KMSC iTunes
Thanks Paul.

I type in chmod -R 777/Volumes/Multimedia/MyMusic

..and in response I get

usage: chmod [-fhv] [-R [-H | -L | -P]] [-a | +a | =a [i][# [ n]]] mode|entry file ...
chmod [-fhv] [-R [-H | -L | -P]] [-E | -C | -N | -i | -I] file ...

..which, with me not being that technical, is worse than latin. Unfortunately it makes no difference to the Jaikoz response. Did I misunderstand?

Per.

P.S. We can get back to the unrecognisable files afterwards, this is more urgent.
Hi,

When loading FLAC files I get a combination of these two error messages:
1) The following audio files are read only, they need to be set to read/write (for a lot of files)
2) The following audio files are not recognised as audio files, they may be corrupt (for just a few files)

The files look fine in Kinsky and they are playable without issues. I do not seem to be able to change folder permissions in Mac Finder (OS X 10.9.5)

I have tried Close Files>Advanced>Empty cache>Exit Jaikoz (several times) without any change to the result.

Kind regards, Per.
Hi Paul

Is this still the way to increase memory? For the last 2 or 3 upgrade versions I don't seem to have that string in Info.plist anymore, and loading my files is a complete pain.

Cheers, Per.
Bump
My issue is that Twonky lists a large number of albums with Genre Unknown despite all tracks showing the correct genre in Jaikoz (posted as a question in a separate thread).

Since I can see other users have Genre related challenges I just want to add that I tried your solution but it did not work for me. My issue seems to be specific to non-flac files.

It is frustrating because I am convinced it is a fairly simple solution once you know what to do.
Hi Paul,

Sorry for the late response. It seems that the files that are now stored under unknown genre are all alac or ogg. The flac files that I have updated seem to get accepted.

There are a lot of files so I am not willing to guarantee if this hypothesis is bullet proof.

Best, Per.
Does it make any difference whether you select a genre from the drop down list, or whether you simply type in, say, Jazz?

Thanks, Per.
Hi,

After auto correcting all files my Linn Dsm does not seem to read my OGG files. I can see them and select them. But the dsm just skips over them to the next flac song. Any ideas?
Hello,
I recently installed a Linn DSM and WD Mybook with Twonky Media Server 5.1.9 installed.

After ripping CDs to FLAC, copying OGG and MP3 files plus downloading a number of albums in FLAC format I was looking at a bit of a mess. So I purchased Jaikoz and set to work cleaning up the tags.

First I did an autocorrect using default settings. After that my 11'000 songs were spread over 200 different genres. This is not what I like to see so I manually changed the Genre field using just 15 standard genres such as Rock, Classical, Jazz, etc.

After that was done it all looks very neat in Jaikoz. The issue is that in Twonky I have 38 Genres and 100s of albums with unknown genre. It does not appear to read Genre correctly from the metadata file.

My question is simply: What is going wrong and what do you suggest I do instead

Thanks in advance, Per.
 
Profile for pped -> Messages posted by pped [14]
Go to:   
Powered by JForum 2.1.6 © JForum Team