[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Messages posted by: 000___000  XML
Profile for 000___000 -> Messages posted by 000___000 [7]
Author Message
Support files sent. Let me know if you haven't received them. Thanks so much for your help.
Oh sorry, I assumed that you received the email I sent yesterday. I'll try sending again with the latest support files attached. Thanks!
Still getting the "java.io.IOException: The specified server cannot perform the requested operation" error when SongKong tries to save files to my NAS share. Have granted rwx permissions across the board and still no luck. Any ideas?
Thanks I will try that now.

I'll gladly email the support files to assist in your continued improvement of this very nifty app. where can i find them and where should i send them?
Also, as per your above suggestion, I attempted to run with the 'Rename files based on metadata' option unticked, and I also unticked 'Move to folder' in the 'File Moving' tab. Still getting the same errors when trying to save, just now occuring when attempting to save the updated file back in its original location. like so:

Feb 29, 2016 8:32:00 AM:Unable to save changes: Z:\Shared Music\iTunes Library\Music\Iron & Wine\Our Endless Numbered Days\02 Naked As We Came.mp3 java.io.IOException: The specified server cannot perform the requested operation 


Just doesn't seem like SongKong can write to the NAS for some reason. Again, to be clear, SongKong is running on Windows 10 (64 bit v). The files are on a network attached WD MyBook Live. "Z:" is mapped to the default public share on the drive.
Hi, thanks for the quick reply.

I should have been a bit clearer. In the actual error message, the values in the curly braces did in fact reference the actual artist, album and track name. That was just my attempt to give you the generic form of the error message. So for example the filename part of the error message was formatted like so:

Z:\Shared Music\Library\Music\Nirvana\Nevermind\01 - Smells Like Teen Spirit.mp3 


But this same error occurred for each file SongKong tried to save before I stopped it.

java.io.IOException: The specified server cannot perform the requested operation 


Sorry for the confusion. Hope this makes things clearer.

Initially, I was getting different errors like:

Feb 29, 2016 12:42:30 AM:File Z:\Shared Music\iTunes Library\Music\The Vitamen\Fun\01 Molested.mp3 cannot be modified

Owner:S-1-5-21-834709840-3110349325-596344468-501
User or Group:S-1-5-21-834709840-3110349325-596344468-501 (Unknown):Allow:Write, Append, Read
User or Group:S-1-22-2-1000 (Unknown):Allow:Write, Append, Read
User or Group:\Everyone (Well-known group):Allow:Read
 


I was able to get these to stop by adjusting permissions on the NAS share for the folders where my files are currently organized. But then the 'Unable to save changes' errors started and seem to specifically have a problem with creating the new moved files in the target directory. And I'm stumped as to what the problem might be. I believe I have r & w permissions granted to owner, group & everybody on the directory in question, but still not working.

Thanks in advance for any insight you might have.
Hello. New to using songKong and I'm attempting to fix files on my NAS from Windows 10.

I think I have read and write permissions set up correctly on the Shares, but I'm still getting the following error repeatedly when SongKong tries to save changes to a song:

Unable to save changes: Z:\Shared Music\Library\Music\{Artist}\{Album}\{Track}.mp3 java.io.IOException: The specified server cannot perform the requested operation 


Any help would be greatly appreciated. I really want this to work so I can be one step closer to freedom from iTunes

thx,
000___000
 
Profile for 000___000 -> Messages posted by 000___000 [7]
Go to:   
Powered by JForum 2.1.6 © JForum Team