[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Messages posted by: vodsonic  XML
Profile for vodsonic -> Messages posted by vodsonic [6]
Author Message
So I finally got around to following up on this. I figured I would try renaming some of my 2-disc sets one last time before generating support files. The mask was applied properly to the file names the first time I tried.

These were the same files, in the same folder, that I had tried to rename this way a half a dozen times over the course of a day or two, and it would never take. I have no idea what changed. I haven't updated Jaikoz, and I'm not even sure I've restarted my computer since then.

I'll post here again if the problem recurs, but for now it's working.
The current version of Jaikoz is failing to apply the "discno" variable when renaming files from metadata. I am using Jaikoz 8.4.1 on OS X El Capitan (10.11.4)

For years, I've used Jaikoz to rename tracks from 2-CD sets using one of these masks:
Code:
discno + '-' + trackno + ' ' + '-'  + ' ' + title

Code:
discno + '-' + (trackno.length>0 ? trackno  + ' ' + '-' :'') + ' ' + title

This normally yields a result that looks like this:

2-03-TrackName.mp3

where 2 is the disc number, and 03 is the track number.

Currently, whenever I try to rename files with Jaikoz, using either mask, it ignores the "discno" variable, and usually ignores the hyphen that comes immediately after it as well.

I think it drops "discno" and the initial hyphen when renaming FLAC files, and includes it, sans "discno" for mp3 files, so the mp3s end up looking like this:
-03-Trackname.mp3

Is this a known bug that will be fixed in the next release?
Thank you, Paul!
And, one more thing I noticed, when I hit the ESC key during a "Set Value" again today: when the blue spinning ball appears, I can still select individual tag fields in the background, and see them highlighted, even though I can't do anything with them and the spinning ball never goes away.

I got a lot of tagging done today, because I managed to refrain from hitting the ESC key...

MTA: OK, it isn't just the escape key. It froze again when I brought up the "Set Value" dialog box, then decided against my edit, and clicked cancel. Same deal as when I hit ESC.
OK, I emailed you the support files, along with some further information. I experimented some more, and here's what I found: I can consistently get Jaikoz to freeze as I described in my original post by doing the following:

1. Right click on a tag field
2. Select "Set Value"
3. Hit the ESC key
4. Click "Cancel" in the "Set Value" dialog box.

It seems to be hitting the ESC key before cancelling "Set Value" that causes the problem. If I don't hit ESC, and even if I do type some other text into the dialog box before canceling, Jaikoz doesn't seem to freeze.

Maybe I just need to try to suppress my lightning-fast *cough* *cough* ancestral DOS-era ESC reflexes...
I'm using Jaikoz 3.7.1, build 1082, on a Mac running Snow Leopard. I've been working with files in my userspace on my internal hard drive, so no external/network drive issues here. I bought Jaikoz two days ago.

Jaikoz freezes for me occasionally, usually when I'm just trying to select a tag or two. This apparently occurs at random, and I haven't noticed anything specific that sets it off, other than that I'll be in the middle of cleaning up some auto-corrected tags, usually trying to select a tag field or two in the Edit screen, and it will hang.

The blue spinning ball appears, and I can't select anything else on the screen. All of the menu options are grayed out, except for the Jaikoz menu, and I can view and use the About and Preferences windows. In Finder's "Force Quit" window, Jaikoz is NOT labeled "not responding". I can grab the window and move it around on the screen. I can also quit Jaikoz, which gives me the option of saving my changes. If I click "Yes", it does save my tags, and then closes. If I start it up again, it works normally for a while.

I've waited 10-15 minutes when it freezes, but it's never come right until I quit and start Jaikoz again. It always happens when I'm in the middle of selecting tags.

The log file will show the last successful action completed on files, and then the next thing it will show is the saving actions, initiated when I try to close the frozen Jaikoz and tell it to save my changes. There are no other error messages.

This problem is especially annoying because it usually happens in the middle of editing a large batch of files, and I don't actually want to save the tags of the ones I haven't inspected yet, since I want the option of reverting to saved.

And, no, I'm not experiencing this problem with any other programs on my Mac at this time.

Any suggestions for how to troubleshoot this? I'd like to get it worked out, because in all other ways, Jaikoz works great and I'm glad I spent the money on it.

MTA build number
 
Profile for vodsonic -> Messages posted by vodsonic [6]
Go to:   
Powered by JForum 2.1.6 © JForum Team