[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Messages posted by: Frodo  XML
Profile for Frodo -> Messages posted by Frodo [30]
Author Message
I am using Jaikoz 9.4.1 on macOS 10.14.2.

Issue is that "View/View this Album at Musicbrainz" is not opening any browser. When I remember correctly the issue appeared with the new Jaikoz version.
@agillis, I also had a ton of CD rips that came from my NAIM HDX.
There was no meta.naim, also not a hidden file. Paul summarized the files you should see in each folder of any NAIM imported CD.

I am almost done with my Flac conversion (with XLD using my Mac) and using SongKong on my Melco N1 as weil as Jaikoz on my Mac too to get metadata embedded into the music files.

Looking back I have to say that the NAIM files were not helpful at all as the metadata that the HDX pulled were really poor. There might have been a few CDs that were only available at the AMG database but in these cases the amount of metadata was kept flat.

Just my 2 cents and others might think differently.
....2nd attempt was working well. I have SongKong 5.13 running on my Melco N1.
Thanks for update Paul.

I unzipped the file with my Windows as well as with my Mac - however still the same errors:
tail -f server.log
 01/01/2019 11:39:34:songkong:remote dbinit
 01/01/2019 11:40:14:songkong:remote started
 debuglogfile is:/mnt/disk1/share/SongKong/Logs/songkong_debug%u-%g.log
 userlogfile is:/mnt/disk1/share/SongKong/Logs/songkong_user%u-%g.log
 03/01/2019 09:51:05:songkong:remote dbinit
 03/01/2019 09:51:45:songkong:remote started
 Error: An unexpected error occurred while trying to open file lib/songkong-5.12.jar
 Error: Unable to access jarfile lib/songkong-5.12.jar
 Error: Unable to access jarfile lib/songkong-5.12.jar
 Error: Unable to access jarfile lib/songkong-5.12.jar
Thank you very much Paul. I have MinimServer as well as SongKong 5.12 Update and running again:

1. Reinstalled MinimServer from scratch
2. Downloaded SongKong for Melco N1 (now version 5.12)
3. installed SongKong using If you have previously installed MinimServer on Melco N1 instructions


Please note that macOS is NOT copying the required .Anas.bak folder if you have can?t see hidden files which is the default setting for Mac users. You need to temporarily make hidden files visible:

Open Terminal and run the following two commands:

 defaults write com.apple.Finder AppleShowAllFiles true
 killall Finder

If you want to switch it back, simply change the true to false.

Merry Christmas everyone.
No worries Paul, enjoy your Christmas break. More on my progress here: http://www.jthink.net/jaikozforum/posts/list/20101.page
Is is possible to reinstall with version 5.12? Where can I download the files please?
There is a script update-minimserver.sh....maybe that is causing the issue? Just thought.
Same issue here. I was trying to running an update and as a result neither MinimServer nor SongKong is running. Is there a workaround possible? I can?t use my Melco yet.

Maybe this Post should be moved into the Melco category?
...as already said I can enter VISA data or bank account data at the end PayPal is insisting to opening a PayPal account.

°....however I dont really understand the big issue with using Paypal....."

In return I don't understand why you don't accept credit card payment as most of software vendors.
That might have been the case in the past but there is no way to pay without having a Paypal account. I am not a Paypal expert either and why should I?

Seems that I can?t upgrade.
Seems that PayPal is needed to pay the upgrade? This is a deal breaker. Credit card would be the preferred payment if that is possible....
Thanks for your swift reply Paul. That's what I thought: that I have to become more familiar with SongKong as it almost contains everything I was used to handle via Jaikoz.

Meanwhile I saw your modified instructions: GREAT improvement - it will make installation much easier!! Thanks a lot.
I was among the lucky ones being invited to the Beta test of SongKong for Melco Remote. There is not "BETA" section available, so forgive me that I am posting here.

First Finding: the application is quicker than I expected. Pulling metadata, saving it and reporting back is just great.

I was mostly using Jaikoz until today and but licenses are valid until end of September and as of today I might only extend SongKong.

Only thing that I am missing are these sections that I am using most in Jaikoz:
  • the whole "Match to Album" section
  • View this Artist at Musicbrainz
  • View this Album at Musicbrainz
  • View this Artist at Discogs
  • View this Album at Discogs

    Maybe it's there and I am just not smart enough to identify where it is.

    Thanks a lot to Paul for the great support to us Melco users.
  • Here is my first feedback as promised. I checked Bill Withers' Greatest Hits album.

    SongKong identified an artwork file with 1.337x1.337 pixel (most probably from Musicbrainz).

    Album Art Downloader found a file with 2.000x2.000 pixel from AllCDCover.
    Sure Paul I should has written it more kindly.....compared to that what Album Art Downloader delivers, Musicbrainz and Discogs files are less great.

    Let me check a couple of albums and I will report back. However, rather than SongKong I am using much more Jaikoz these days as I am having more control over the metadata.

    I guess that this feature is being implemented into Jaikoz soon. Thanks for your GREAT work that is making a HUGE difference in metadata since I am using it!!!!
    This is an old thread but I would like to raise it once more.

    I am using SongKong as well as Jaikoz on macOS and both are working great with one exception......the artwork provided is poor because Musicbrainz and Discogs are providing poor artwork.

    So after finalizing the metadata I always fire update my Win10 VM and use a small app that is called Album Art Downloader. That is basically pulling pictures from various servers and is usually providing great covers.

    That functionality might be a great addition to the jThink SW.

    Good morning,
    I removed all previous reports and stuff as I had a crash yesterday both iTunes and SongKong.

    I deleted the non-HD file but no change.

    All of my HD albums are under [no album] that is the reason why I can just find it via folder view.
    Thanks Paul.

    This was a 192/24 album that I bought from HDtracks. It contains 6 tracks which is different from the vinyl or CD version:
  • So What
  • Freddie Freeloader
  • Blue in Green
  • All Blues
  • Flamenco Sketches
  • Flamenco Sketches (alternate take)

    SongKong is making this:
    Kind of Blue [HD] (Disc 1) for all songs 1-5
    Kind of Blue (Disc 2) for song 6

    When I browse my library I can't find the first 5 songs anymore. IS_HD equals 1 for the first 5 songs but not for the last song.

    The spreadsheet is attached below.
  • I was please to see the announcement of SongKongs HD Release. I added the following to Minimserver:

    is_hd=1:HD Musik, is_hd_copy=0:Non-HD Musik


    The respective option in SongKong was activated but after a rescan Minim is still not showing any HD albums by browsing through my library. Anything that I overlooked?

    Oh and what can we expect this feature in Jaikoz?
    Great fix!! Thanks a lot Paul.
    Yes that was a typo. Apologize.
    The issue around ID3v2.22 vs. IDv24 or ID3v24 is fixed. I am saving all files that throw out error messages in Minimserver log again by using IDv24 and the messages are gone.

    Is menu bar issue is not fixed.
    That?s an interesting finding Paul. I rebooted into an English environment and found the menu bar where it should be. Interestingly enough in German

    I can modify my tags for the time being. Thanks for your workaround.
    Thanks a lot Paul, the IDE issue to me is solved and I think that we would be better off to use this link for the High Sierra issue: http://www.jthink.net/jaikozforum/posts/list/19545.page
    This was the first thing that macOS High Sierra was asking to install:
     java -version
     java version "1.7.0_51"
     Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
     Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)
    No it is the final version of macOS High Sierra
    I am having the final macOS High Sierra installed, never used any Beta. I used SongKong for Melco 4.11 and updated today to 4.12. It doesn't show any menubar. The same with Jaikoz (latest version).
    High Sierra is out and the issue persists with both Jaikoz & SongKong. What is the plan?
    When I was start tagging my library with SongKong for Melco and Jaikoz I saw more an more of these messages:

    Warning: ID3v2 TYE frame has incorrect value '2010-03-19' at offset 85528527 in file Sol Gabetta/Elgar Cello Concerto/1-01 Elgar_ Cello Concerto In E Minor, Op. 85 - 1. Adagio, Moderato.aif (length 85772720)
     Warning: ID3v2 TYE frame has incorrect value '2010-03-19' at offset 48585668 in file Sol Gabetta/Elgar Cello Concerto/1-02 Elgar_ Cello Concerto In E Minor, Op. 85 - 2. Lento, Allegro Molto.aif (length 48829860)
     Warning: ID3v2 TYE frame has incorrect value '2010-03-19' at offset 45880854 in file Sol Gabetta/Elgar Cello Concerto/1-03 Elgar_ Cello Concerto In E Minor, Op. 85 - 3. Adagio.aif (length 46125046)
     Warning: ID3v2 TYE frame has incorrect value '2010-03-19' at offset 120796793 in file Sol Gabetta/Elgar Cello Concerto/1-04 Elgar_ Cello Concerto In E Minor, Op. 85 - 4. Allegro Moderato.aif (length 121040960)
     Warning: ID3v2 TYE frame has incorrect value '2010-03-19' at offset 51596143 in file Sol Gabetta/Elgar Cello Concerto/1-05 Elgar_ Sospiri.aif (length 51840368)
     Warning: ID3v2 TYE frame has incorrect value '2010-03-19' at offset 32138053 in file Sol Gabetta/Elgar Cello Concerto/1-06 Elgar_ Salut D'Amour.aif

    According to Simon Nash, the developer of Minimserver this is because the TYE frame (ID3v2.2) must contain a 4-digit year rather year-month-day.

    Would it be possible to add a switch that makes both apps more compatible to Minimserver?
    Profile for Frodo -> Messages posted by Frodo [30]
    Go to:   
    Powered by JForum 2.1.6 © JForum Team