[Logo] Jaikoz and SongKong Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Messages posted by: ozone  XML
Profile for ozone -> Messages posted by ozone [14]
Author Message
For some reason when I save a file to ID3v1v23 the "title" in the explorer view of Windows 7 shows what looks to be Chinese characters instead of the English names for my songs. Everything is fine in Winamp though...

In order to fix the "title" view in Windows 7 I need to save the songs as ID3v1v24 but my Winamp is not compatible with 2.4.

There are two reasons I am lead to believe the issue is something in Jaikoz:

1. All my songs which I have not edited with Jaikoz are in v2.3 format and show up fine in Windows 7 explorer. It is not until I edit something in Jaikoz that the "title" then becomes screwed up.

2. Also, when I go into Winamp and click on the ID3v1 tag if I click the "Copy to ID3v2" it fixes the problem.

Thoughts?
I downloaded the latest version (Jaikoz 3.3.2 Build 1070) and when I clicked to run the program, after installation was done, I got an error message:

"java.sql.BatchUpdateException: Table/View 'ARTWORK' does not exist."

I never had a problem with any older Jaikoz releases. But yeah, so I can't get it to run now
Ah, from the Manual it states:

The correction will take the following steps:

Generate a list of audio files where it may be useful to extract information from the filename. Tags which already contain an Artist,Title and Album value are not included.
 


So because something already existed in the artist tag, it skipped it. This type of issue I guess arises when you have a ID3v1 and the artist or album name is truncated, and a ID3v2 does not exist. So is there some way that you could implement some AI to determine this and match this stuff up instead of Jaikoz skipping over it? I don't know if it is possible but that would be great.

Oh, and this situation is also where you are dealing with tracks that don't have music brain data which are a lot of vinyl tracks and trance mixes that don't have associated albums.
I can't pinpoint the bug, so let me list exactly what is happening:

Jaikoz 1.94

FILENAME: Christian Marchi Pres. Love Project ft. Glenys - Love.mp3
ARTIST TAG: Christian Marchi Pres. Love Pr
TITLE TAG: Love

Correct Tags From Filename Settings:
Split the filename using these values (tags from filename word separator)
[x] Match values..
[x] Ignore word..
[x] Ignore case..
[x] Enable ignoring common... (default word remover)
Split words using these values (default word separator)

Contents of Default Word Separator:
(default settings)

Contents of Tags from Filename Word Separator:
(default settings)

---- RESULT & ANALYSIS -----

(I first want to point out an obvious bug; If I select Default Word Separator for the "Split the Filename Using..." in the correct tags from filename setting, it doesn't save this selection when I click "ok". When I re-open the correct tags from filename settings window, it just defaults back to "tags from filename word separator"...)

With the above settings, I would figure that Jaikoz would split the filename at the first "-" because that is the separator in "Tags from Filename Word Separator". If that were the case, then Jaikoz should replace the Title field with "Christian Marchi Pres. Love Project ft. Glenys" but it does not. Upon running the correct tags from filename, there are absolutely no changes to the artist or title.

So I'm stumped at why Jaikoz can't do what I'm trying to get it to do. Is it a bug or am I doing something wrong?
Sorry for so many posts. I figured out an easy fix you can do to implement this. Allow the word replacer to work on a case sensitive basis. That way I could have it replace "And" with "and". Currently it can't do this.
Guess I wasn't logged in for the post so I can't edit it. I also wanted to suggest that if you do implement this, then have Jaikoz not only not capitalize those words, but also force them to lower case (so that it catches any of them already in uppercase).
In word replacer I set it to replace -->`<-- with -->'<--
(without the arrows of course)

Well, it doesn't replace it for some reason.

Before replace: Love Won`t Wait Vinyl
After replace: Love Won`T Wait Vinyl
I want to be able to choose in the options menu whether I want the recording time displayed as... YEAR-MONTH-DAY (i.e., 2007-12-06) or YEAR (i.e., 2007).

If implementing this would take some time, then can you at least in the next patch standardize the current method? Currently, Jaikoz appears to do no analysis during auto correction on the recording time. So you could have 1 album with five files in YEAR-MONTH-DAY format, and six files in YEAR format. I wish it would tidy the recording time up automatically for me instead of leaving songs in the same album with a different format.

paultaylor wrote:
I tested this out myself and it works correctly (with the .), if I run it again the dot disappears because the dot is included in the default punctuation remover. (it is not removed the first time because the punctuation remover is run before the word replacer). May be this is the problem you are encountering ?
 


Ah... I forgot that the default settings for auto-corrector apply, for example, artist corrector 3x times. So after setting it to just apply correction once then the period is left in.

Thanks!
Thanks for the speedy fix on the "\" issue for the word replacer. However, the "." is not showing up. So, if I set "feat" to be replaced by "ft." it is replaced by "ft" (i.e., so it's missing the period on the end)
There is already a find option, but how about a replace option too? For example, the apostrophe character. Sometimes people use ` and sometimes people use ' and other people use other ascii characters for it. Personally, I prefer '. Anyway, there is no way for me to change all the ` to ' in Jaikoz. So a find-replace would be killer (not just for apostrophe characters, but for any character in a particular column).

Also, have you ever tried Magic File Renamer? I have to be honest, the only reason why I don't solely use that is because your program has smart-matching and the musicbrainz lookup and MFR doesn't. But other than that, Magic File Renamer has some really badass features. You can build renaming functions and all kinds of stuff. The reason I bring it up is I was curious if you were considering building that type of functionality into Jaikoz? I would really recommend checking it out if you have not.

paultaylor wrote:

ozone wrote:
I
This also happens for example when I told it to replace "feat" with "ft."
It ends up replacing "feat" with "ft\."
Why is it doing this? 

But I havent been able to replicate this case, could you double check and provide the full text being modified, and the full contents of your word replacer, you can send screenshots instead if that is easier.

paul 


1) Set the Artist for a mp3 to "Tom Cloud feat Tiff Lacey"
2) Set the word replacer to replace "feat" with "ft." (note: you must include the period... so, 'ft.')
3) Enable the replacer for the Artist column
4) Hit F2 to apply the corrector to the artist column

The result will be "Tom Cloud Ft\. Tiff Lacey"


I can send you a screen shot, but it's exactly as I said. By the way, on another note, some ascii characters don't show up properly in the Tags; rather, they show up as squares. Do you know what I'm talking about? Maybe you already know about it and are working on it, but if not I can screenie it.
I want an option for "Title Case Capitalization"
This option will have a list of words of my choosing that I do not want capitalized UNLESS they begin the sentence.

For example, upon enabling Title Case Capitalization, I could enter a list of words such as "a an the and or of it as". Then, this does the following:

Artist: "Jack Of Trades" becomes "Jack of Trades"

Title: "Frame Of Mind" becomes "Frame of Mind"

Album: "Of Another Blood" remains the same because "of" begins the sentence
In the replacement list I had the word "and" replaced to "&". However when Jaikoz does this, it replaces "and" with "\&".

This also happens for example when I told it to replace "feat" with "ft."
It ends up replacing "feat" with "ft\."

Why is it doing this?
 
Profile for ozone -> Messages posted by ozone [14]
Go to:   
Powered by JForum 2.1.6 © JForum Team